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LESSON 1 -  
CREATING BASIC FORMS  

In this lesson, you will learn how to: 

• Use forms  

• Use the Form Wizard  

• View records in a form  

• Print records in a form  

• Base a form on a query  

• Use AutoForm  

• Add a record using a form  
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USING FORMS 

 Discussion 
Forms, like datasheets, can be used for viewing and editing data. However, you can 
also use them to present data in a more attractive format and layout than a datasheet. 
They can be designed to display all the fields for a record on one screen, eliminating 
the need to scroll to display all the fields. You can also display data from related 
tables in a form. 
 
Access includes four basic types of forms: columnar, tabular, datasheet, and justified. 
In a columnar form, the field names are listed on the left side of the form, with the 
field values in a column to the right. If space on the screen permits, there can be more 
than one column. In a tabular form, the field names are listed across the top of the 
form with the values in the appropriate columns beneath them. A datasheet form is 
similar to Datasheet view for tables and queries. In a justified form, the field names 
and values appear in alternate rows evenly spaced across the page. Field values appear 
under the appropriate field names. 
 

USING THE FORM WIZARD 

 Discussion 
You can create a form quickly and easily using the Form Wizard. The Form Wizard 
guides you through the process of creating a form. First, you choose the table or query 
on which you want to base the form and then you select the fields you want to include. 
Next, you select the type of layout for the form: columnar, tabular, datasheet, or 
justified. In the next step, you choose a style from a number of different styles with 
various backgrounds and color schemes. The last step in the wizard is to name the 
form. 
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The Form Wizard 

 
  

 
If you base a form on an object that is associated with two or 
more tables, the Form Wizard asks you on which table you 
want to base the view of the data. This page in the Form 
Wizard appears after you have selected the fields you want to 
use for your form and before you are asked if you want to 
select a grouping level. 

  

 
You can also activate the Form Wizard by double-clicking the 
Create form by using wizard option in the Forms object list 
in the Database window, or by selecting the Insert menu and 
then selecting the Form command. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Forms object list. 

3. Select the New button  on the Database window toolbar. 

4. Select Form Wizard. 

5. Select OK. 
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6. Select the Tables/Queries list. 

7. Select the table or query on which you want to base the form. 

8. Add the desired field(s) from the Available Fields list box. 

9. Select Next. 

10. Select the layout for the form. 

11. Select Next. 

12. Select the style for the form. 

13. Select Next. 

14. Type a name for the form. 

15. Select Finish. 

 

VIEWING RECORDS IN A FORM 

 Discussion 
Navigating records in a form is similar to navigating records in Datasheet view. You 
use buttons on the bottom of the Form view window to navigate in a form. The 
buttons available in Form view are listed in the following table: 

 
Button Description 

 Displays the first record 

 Displays the previous record 

 Displays the next record 

 Displays the last record 
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A record displayed in a form created with the Form Wizard 

 
  

 
You can also use the keyboard to move through records. The 
[Ctrl+Home] key combination displays the first record while 
the [Ctrl+End] key combination displays the last record. 

  

 
If the report is columnar, the [Page Down] and [Page Up] 
keys display the next and previous records, respectively. 

  

 
You can also go directly to a record by selecting the record 
number in the Record text box, typing the number of the 
record you want to display, and pressing [Enter]. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Forms object list. 

3. Open the form in Form view. 

4. Click the Last Record button  at the bottom of the Form view 
window. 

5. Click the First Record button  at the bottom of the Form view 
window. 

6. Click the Next Record button  at the bottom of the Form view 
window. 
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7. Click the Previous Record button  at the bottom of the Form 
view window. 

 

PRINTING RECORDS IN A FORM 

 Discussion 
You can print the current form using the Print dialog box. You can choose to print all 
the records, specified pages, or selected records.  
 
If you use the Print button to print all the data, Access fits as many whole forms as 
possible on a single page. It does not break a form in the middle. However, if a form is 
large and there are numerous records in a table, you may be using a large amount of 
paper and printer time. 
 
The Print dialog box, on the other hand, allows you to select specific pages or records 
to print, thereby saving time and paper. 
 

  

 
You can also open the Print dialog box by right-clicking in the 
Database window and then selecting the Print command. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Forms object list. 

3. Open the form in Form view. 

4. Select the File menu. 

5. Select the Print command. 

6. Select the Selected Record(s) option. 

7. Select OK. 
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BASING A FORM ON A QUERY 

 Discussion 
Forms can draw information from a query. If the RecordSet in the query cannot be 
updated, then you cannot use the form to add or edit records. However, the form can 
be used to present the RecordSet in a more attractive manner. 
 

  

 
If you create a form based on a query with a join line between 
two different fields, the Form Wizard asks you how you want 
to view the data. 

  

 
You can also activate the Form Wizard by double-clicking the 
Create form by using wizard option in the Forms object list 
in the Database window, or by selecting the Insert menu and 
then selecting the Form command. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Forms object list. 

3. Select the New button  on the Database window toolbar. 

4. Select Form Wizard. 

5. Select OK. 

6. Select the Tables/Queries list. 

7. Select the table or query on which you want to base the form. 

8. Add the desired field(s) from the Available Fields list box. 

9. Select Next. 

10. Select the layout for the form. 

11. Select Next. 

12. Select the style for the form. 

13. Select Next. 

14. Type a name for the form. 
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15. Select Finish. 

 

USING AUTOFORM 

 Discussion 
The fastest way to create a form is to use AutoForm. AutoForm creates a simple 
columnar, tabular, or datasheet form from a selected table or query automatically, 
without displaying any dialog boxes or needing any input. However, you must 
remember to select a table or query before you create the form. All fields in the table 
or query will appear on the form and the title of the form is the name of the table or 
query. 
 
AutoForm does not save the form for you automatically. When you close the form for 
the first time, a message box opens, asking if you want to save the changes. 
 
Access includes three AutoForm options in the New Form dialog box. There is also an 
AutoForm option in the New Object list and on the Insert menu. These options do 
not produce the same result. The AutoForm options in the New Form dialog box 
produce columnar or tabular reports that contain formatting, headers, and footers. The 
AutoForm option in the New Object list or on the Insert menu is very simple; there 
are no formats, headers, or footers. 

 
A form created with AutoForm 

 
  

 
AutoForm options for the three types of forms are available in 
the New Form dialog box. If you choose one of these options, 
you must select the table or query in the New Form dialog 
box. The wizard creates the form using the most recent 
defaults for the style. 
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You can also create a form using AutoForm by selecting the 
table or query you want to use, selecting the Insert menu, and 
then selecting the AutoForm command, or by clicking the 
arrow on the New Object button on the Database toolbar and 
selecting the AutoForm command. When you use one of 
these methods, the form appears in a standard columnar 
format. 

  

 
To use any AutoForm option, you must select a table or query 
before activating the option. 

  
 

 Steps 

1. Open the desired database. 

2. Select the Forms object list. 

3. Select the New button  on the Database window toolbar. 

4. Select the AutoForm option you want to use. 

5. Select the Choose the table or query where the object’s data 
comes from list. 

6. Select the desired table or query. 

7. Select OK. 

 

ADDING A RECORD USING A FORM 

 Discussion 
Forms are frequently used to add records. Well designed forms are easier to work with 
than tables because all the fields can appear on screen at once, eliminating the need to 
scroll. 
 
You can use the [Enter] key to move between fields when you are entering data. If 
you want to skip several fields, you can press the [Tab] key until the insertion point 
appears in the desired field or click in the field where you want to enter data. If you 
press the [Enter] key after entering data in the last field of a record, Access 
automatically saves the record and displays a blank form to enter another record. 
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You use the [Shift+Tab] key combination to move to the 
previous field. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Forms object list. 

3. Open the form in Form view. 

4. Click the New Record button  on the Form View toolbar. 

5. Type the desired data in the first field. 

6. Press [Enter]. 

7. Enter data in the fields as desired. 

 



 

 

LESSON 2 -  
CREATING BASIC REPORTS  

In this lesson, you will learn how to: 

• Use reports  

• Use the Report Wizard  

• Use Print Preview  

• Print pages of a report  

• Base a report on a query  

• Use AutoReport  
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USING REPORTS 

 Discussion 
Although you can print records in a table or form, a report provides more precise 
control over the final output. Reports can include page headers and footers, calculated 
totals and subtotals, and even graphics. Reports can be used for invoices, orders, 
presentations, and mailing labels. 
 
There are two basic types of reports: columnar and tabular. In a columnar report, the 
field names are listed on the left side of the report, with the field values listed on the 
right. If space on the page permits, there can be more than one column. In a tabular 
report, the field names are listed across the top of the report, with the field values in 
the appropriate columns beneath them. 
 
Reports can include data from a single table or related tables. Reports can also be 
based on queries. 
 

USING THE REPORT WIZARD 

 Discussion 
You can create a report quickly and easily using the Report Wizard. There are seven 
basic steps in creating a report using the Report Wizard: 

 
1. Selecting the table(s) you want to use and the fields you want to 

include in the report. 

2. Grouping the data. 

3. Adding grouping levels. 

4. Sorting the data. 

5. Selecting the layout. 

6. Selecting the style. 

7. Naming the report. 

 
When you have finished creating the report, the Report Wizard displays the report in 
Print Preview. This option allows you to view the report before you print it. 
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A report created with the Report Wizard 

 
  

 
If you base a report on an object that is only associated with 
one table, you do not need to specify the table on which you 
want to base the view of the data. 

  

  
You can also activate the Report Wizard by double-clicking 
the Create report by using wizard option in the Reports 
object list in the Database window, or by selecting the Insert 
menu and then selecting the Report command. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Reports object list. 

3. Select the New button  on the Database window toolbar. 

4. Select Report Wizard. 

5. Select OK. 

6. Select the Tables/Queries list. 

7. Select the table or query on which you want to base the report. 

8. Add the desired field(s) from the Available Fields list box. 

9. Select the Tables/Queries list. 
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10. Select the next table or query on which you want to base the report. 

11. Add the desired field(s) from the Available Fields list box. 

12. Select Next. 

13. Select how you want to view the data in the How do you want to 
view your data? list box. 

14. Select Next. 

15. Select a grouping level in the Do you want to add any grouping 
level? list box, if desired. 

16. Select Next. 

17. Select the appropriate field list. 

18. Select the field by which you want to sort. 

19. Select Next. 

20. Select the desired layout for the report under Layout. 

21. Select the desired orientation for the report under Orientation. 

22. Select Next. 

23. Select the desired style for the report. 

24. Select Next. 

25. Type a name for the report. 

26. Select Finish. 

 

USING PRINT PREVIEW 

 Discussion 
When you open a report, it appears in Print Preview. This option allows you to see the 
way the report looks before you print it. 
 
The Print Preview window has options to help you view the report. By default, the 
report appears magnified at 100%, which is the same size as the printout. You can also 
zoom out to see more of the report or zoom in to see a portion of the report in more 
detail. You can display the report in One Page, Two Pages, or Multiple Pages view. 
The buttons at the bottom of the window allow you to navigate through the pages and 
the scroll bars allow you to view different parts of the page. 
 

  

 
You cannot edit data in a report. 
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You can also access Print Preview by right-clicking in the 
Database window and then selecting the Print Preview 
command. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Reports object list. 

3. Select the report you want to preview. 

4. Select the Preview button  on the Database window 
toolbar. 

5. Click the Zoom button  on the Print Preview toolbar on the 
Print Preview toolbar to change the magnification to fit the window. 

6. Click the Two Pages button  on the Print Preview toolbar to 
display two pages of the report. 

7. Click the One Page button  on the Print Preview toolbar to 
display one page of the report. 

8. Click the Zoom button  on the Print Preview toolbar to change 
the magnification back to 100%. 

9. Click the Next Page button  at the bottom of the Print Preview 
window to display the next page of the report. 

10. Click the Last Page button  at the bottom of the Print Preview 
window to display the last page of the report. 

11. Click the Previous Page button  at the bottom of the Print 
Preview window to display the previous page of the report. 

12. Click the First Page button  at the bottom of the Print Preview 
window to display the first page of the report. 
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PRINTING PAGES OF A REPORT 

 Discussion 
You can choose to print specific pages of a report. This option is useful if the report 
contains numerous pages and you only need information from particular pages. The 
Print dialog box allows you to specify specific pages to print. 
 

  

 
You can print a report from the Database window or from 
Print Preview. 

  

 
To print an entire report, click the Print button. 

  

 
You can also open the Print dialog box by right-clicking in the 
Database window and then selecting the Print command. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Reports object list. 

3. Select the report you want to print. 

4. Select the File menu. 

5. Select the Print command. 

6. Select the Pages option. 

7. Type the number of the first page you want to print. 

8. Select the To text box. 

9. Type the number of the last page you want to print. 

10. Select OK. 
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BASING A REPORT ON A QUERY 

 Discussion 
You can use a query as the basis for a report. The RecordSet of the query appears as 
the data in the report and changes in the RecordSet data are reflected in the report the 
next time it is opened or printed. 

 
A report based on a query 

 
  

 
If you base the report on two or more tables, the Report 
Wizard asks you on which table you want to base the view of 
the data. This Report Wizard page appears after you have 
selected the fields you want to use for your report and before 
you are asked if you want to select a grouping level. 

  

 
You can also activate the Report Wizard by double-clicking 
the Create report by using wizard option in the Reports 
object list in the Database window, or by selecting the Insert 
menu and then selecting the Report command. 

  
 

 Steps 

1. Open the desired database. 

2. Display the Reports object list. 
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3. Select the New button  on the Database window toolbar. 

4. Select Report Wizard. 

5. Select OK. 

6. Select the Tables/Queries list. 

7. Select the table or query on which you want to base the report. 

8. Add the desired field(s) from the Available Fields list box. 

9. Select Next. 

10. Select how you want to view the data in the How do you want to 
view your data? list box. 

11. Select Next. 

12. Select a grouping level in the Do you want to add any grouping 
level? list box, if desired. 

13. Select Next. 

14. Select the appropriate field arrow. 

15. Select the field by which you want to sort. 

16. Select Next. 

17. Select the desired layout for the report under Layout. 

18. Select the desired orientation for the report under Orientation. 

19. Select Next. 

20. Select the desired style for the report. 

21. Select Next. 

22. Type a name for the report. 

23. Select Finish. 

 

USING AUTOREPORT 

 Discussion 
You can use AutoReport to create a report quickly. AutoReport creates a simple 
columnar or tabular report from a selected table or query automatically, without 
displaying any dialog boxes or needing any input. However, you must remember to 
select a table or query first. All fields in the table or query will appear in the report 
and the title of the report is the name of the table or query. 
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AutoReport does not save the report for you automatically. The first time you close 
the report, a message box opens, asking if you want to save the changes. 
 
Access includes two AutoReport options in the New Report dialog box. There is also 
an AutoReport option in the New Object list and on the Insert menu. These options 
do not produce the same result. The AutoReport options in the New Report dialog box 
produce columnar or tabular reports that contain formatting, headers, and footers. The 
AutoReport option in the New Object list or on the Insert menu is very simple; there 
are no formats, headers, or footers. 

 
The New Report dialog box 

 
  

 
AutoReport options for the two types of reports are available 
in the New Report dialog box. If you choose one of these 
options, you must select the table or query in the New Report 
dialog box. The wizard creates the report using the most recent 
defaults for the style. 

  

 
To use any AutoReport option, you must select a table or 
query before activating the option. 

  

 
You can also create a report using AutoReport by selecting the 
table or query you want to use, selecting the Insert menu, and 
then selecting the AutoForm command, or by clicking the 
arrow on the New Object button on the Database toolbar and 
then selecting the AutoReport command. 
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 Steps 

1. Open the desired database. 

2. Select the Reports object list. 

3. Select the New button  on the Database window toolbar. 

4. Select the AutoReport option you want to use. 

5. Select the Choose the table or query where the object’s data 
comes from list. 

6. Select the desired table or query. 

7. Select OK. 

 

 Step-by-Step 
From the Student Data directory, open WORLD7.MDB. 
Use AutoReport to create a report based on a table. 
 
If necessary, display the Reports object list. 

 

Steps Practice Data 
1. Select the New button on the Database 

window toolbar. 
The New Report dialog box opens. 

Click  

2. Select the AutoReport option you want 
to use. 
The AutoReport option is selected and 
a description of the AutoReport option 
appears in the left panel of the New 
Report dialog box. 

Click AutoReport: 
Columnar 

3. Select the Choose the table or query 
where the object’s data comes from 
list. 
A list of tables and queries in the 
database appears. 

Click Choose the table or 
query where the object’s 
data comes from  

4. Select the desired table or query. 
The table or query name appears in 
the Choose the table or query where 
the object’s data comes from text box. 

Click Customers 
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Steps Practice Data 
5. Select OK. 

The New Report dialog box closes and 
the report appears in Print Preview. 

Click OK 

 
View the report. Close Print Preview and save the report as Customers. 
Close WORLD7.MDB. 



 

 

LESSON 3 -  
USING ADVANCED FORM DESIGN  

In this lesson, you will learn how to: 

• Use forms in Design view  

• Create a combo box  

• Create a list box  

• Create an option group  

• Set the tab order automatically  

• Set the tab order manually  

• Add a form header and footer  

• Create a blank form  
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USING FORMS IN DESIGN VIEW 

 Discussion 
You can create or customize a form in Design view. A form has three basic sections: 
Detail, Form Header/Footer, and Page Header/Footer. 
 
The Detail section contains the information from the table or query. You create 
controls in the Detail section that allow you to display or enter information. Access 
provides a variety of control types you can add to the form to simplify the data entry 
process. For example, you can replace a text box with a list box or an option group so 
that you can select a value rather than type it during data entry. In many cases, it is 
quicker and easier to select a value from a list rather than to remember the value you 
want to use and then type it. Having a list of choices also helps to ensure the 
consistency of the data being entered. 
 
The Form Header and Form Footer sections display at the top and bottom of a form 
in Form view. They are stationary when you scroll the Detail section, making them 
useful for displaying titles or instructions you want visible on the form at all times. If 
you print the form, these sections appear at the top of the first page and at the bottom 
of the last page. You can also place controls, including images, labels, and fields in 
the form header or footer. 
 
The Page Header and Page Footer sections display at the top and bottom of the form 
in Design view. They do not appear in Form view. They display at the top and bottom 
of every page when the form is printed. Page headers and footers can contain images, 
lines, text, or any other controls you want printed on every page. 
 
When you enable the display of either header and footer section, both the header and 
the footer appear. You can drag the header and footer sections to size them. 

 
A form with form and page headers and footers in Design view 
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To save a table, query, form, or report in the HTML format so 
that it may be viewed in a browser, the object must be 
exported as HTML. To export an object, select the object, 
select the File menu, and then select the Export command. In 
the Export As dialog box, enter a file name in the File name 
text box, select HTML Documents from the Save as type 
list, and select a storage location. If you want to immediately 
view the object in a browser upon saving, select the AutoStart 
option. When you have finished making selections, select the 
Save button. 

  
 

CREATING A COMBO BOX 

 Discussion 
You can create a combo box on a form. A combo box provides you with a list of 
values from which you can choose. Choosing from a list is much faster and more 
accurate than remembering a value to be typed. However, you can also type a value 
directly into a combo box if the appropriate value is not available from the list. 
 
A combo box can be bound to a field, meaning that when you select or enter a value, 
the value is entered into that field in the corresponding table. A combo box can also be 
unbound, meaning that when you select or enter a value, it is held in memory to be 
used in another control or calculation. 
 
Access has a Combo Box Wizard that guides you through the process of creating a 
combo box. You can select the list of values from an existing table or query, or you 
can create the values for the list yourself. If you choose to select the list from an 
existing table or query, the wizard prompts you to enter the table or query and the 
field name. If you choose to create the list of values yourself, the wizard displays a 
column for the entries. Either way, once the values are entered into the wizard, you 
then specify whether the values should be entered into a field in the table or held in 
memory for later use. You complete the combo box by entering a label. 
 
When you use the Combo Box tool, the mouse pointer changes into a copy of the tool 
with a plus sign (+) above and to the left of it. 
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A combo box added to a form 

 

 Steps 

1. Open the desired database. 

2. Open the desired form in Design view. 

3. Display the toolbox. 

4. Click the Combo Box tool  in the toolbox. 

5. Click in the form in the location where you want the combo box to 
appear. 

6. Select the desired option for the source of the combo box values. 

7. Select Next. 

8. Select the desired view option. 

9. Select the table or query containing the values for the combo box in 
the Which table or query should provide the values for your 
combo box? list box. 

10. Select Next. 

11. Select the field containing the values from the Available Fields list 
box. 

12. Select Next. 

13. Adjust the width of the column, as necessary.  
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14. Select Next. 

15. Select the desired storage option for the field. 

16. Select the Store that value in this field list, if applicable. 

17. Select the desired field name, if applicable. 

18. Select Next. 

19. Type a label for the combo box. 

20. Select Finish. 

 

CREATING A LIST BOX 

 Discussion 
You can create a list box on a form. A list box provides you with a list of values from 
which you can choose. Choosing from a list is much faster and more accurate than 
remembering a value to be typed. However, unlike a combo box, you can only choose 
an item from the list; values not present on the list cannot be entered into the table. 
 
A list box can be bound to a field, meaning that when you select or enter a value, the 
value is entered into a field in the corresponding table. A list box can also be unbound, 
meaning that when you select or enter a value, it is held in memory to be used in 
another control or calculation. 
 
Access has a List Box Wizard that guides you through the process of creating a list 
box. You can select the list of values from an existing table or query, or you can create 
the values for the list yourself. If you choose to select the list from an existing table or 
query, the wizard prompts you to enter the table or query and the field name. If you 
choose to create the list of values yourself, the wizard displays a column for the 
entries. Either way, once the values are entered into the wizard, you then specify 
whether the values should be entered into a field in the table or held in memory for 
later use.  
 
When you use the List Box tool, the mouse pointer changes into a copy of the tool 
with a plus sign (+) above and to the left of it. The center of the plus sign (+) indicates 
the position of the top left corner of the list box. 
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A list box added to a form 

 

 Steps 

1. Open the desired database. 

2. Open the desired form in Design view. 

3. Display the toolbox. 

4. Click the List Box tool  in the toolbox. 

5. Drag to draw the list box in the desired location on the form. 

6. Select the desired option for the source of the list box values. 

7. Select Next. 

8. Type the number of columns for the list box. 

9. Press [Tab]. 

10. Type the first value for the list box. 

11. Press [Tab]. 

12. Continue to type values as desired. 

13. Adjust the width of the column, as necessary. 

14. Select Next. 

15. Select the desired storage option for the field. 

16. Select the Store that value in this field list, if applicable. 
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17. Select the desired field name, if applicable. 

18. Select Next. 

19. Type a label for the list box. 

20. Select Finish. 

 

CREATING AN OPTION GROUP 

 Discussion 
You can create an option group on a form. An option group provides you with a 
limited set of values from which you can choose. Choosing from a set of values is 
often much faster and more accurate than remembering a value to be typed. With an 
option group, you can only select one option from the set of alternatives. Therefore, 
option groups are best utilized when there are five or less values from which to 
choose. Adding more than five values to an option group can crowd a form and is less 
effective for quick data entry. 
 
An option group has a frame that encloses the set of values. These values appear 
beside option buttons or check boxes, or on top of toggle buttons. 
 
An option group can be bound to a field in a table or query. However, only the frame 
is bound to the field. Within the frame, Access assigns each option a numeric value. 
When the option is selected, this numeric value is entered into the corresponding 
table. Access assigns a number because the value of an option group cannot be text. 
For example, you can use an option group to display a Yes/No field. By default, 
Access assigns the number 1 to the Yes option, and the number 2 to the No option. 
You only see the Yes and No options on the form, but Access stores the Yes option as 
the number 1 in the corresponding table and the No option as the number 2. 
 
Access has an Option Group Wizard that guides you through the process of creating 
an option group. 
 
When you use the Option Group tool, the mouse pointer changes into a copy of the 
tool with a plus sign (+) above and to the left of it. The center of the plus sign (+) 
indicates the position of the top left corner of the option group. 
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An option group added to a form 

 
  

 
The Option Group Wizard is not included in the default 
installation. You can choose to install it with the initial 
installation, or it can be installed by itself at a later time. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired form in Design view.  

3. Display the toolbox. 

4. Click the Option Group tool  in the toolbox. 

5. Drag to draw the option group in the desired location on the form. 

6. Type the desired label for the first option. 

7. Press [Tab]. 

8. Type other labels as desired. 

9. Select Next. 

10. Select the desired option for the default. 

11. Select Next. 

12. Type the value for the first label. 

13. Press [Tab]. 
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14. Type other values as necessary. 

15. Select Next. 

16. Select the desired storage option for the field. 

17. Select the Store the value in this field list, if applicable. 

18. Select the desired field name, if applicable. 

19. Select Next. 

20. Select the desired option for the control type. 

21. Select the desired style option. 

22. Select Next. 

23. Type the caption for the option group. 

24. Select Finish. 

 

SETTING THE TAB ORDER AUTOMATICALLY 

 Discussion 
The tab order determines the order in which form fields and controls are selected 
when you press the [Tab] key during data entry. The default tab order is the order in 
which the fields or controls were added to the form. If you have added, rearranged, or 
deleted fields or controls, the tab order may not be suitable for data entry. You can 
choose to have Access automatically rearrange the tab order to reflect the order of the 
fields on the form. The fields are then accessed from left to right across each row. 
 

  

 
You can also open the Tab Order dialog box by right-clicking 
in the Design window and then selecting the Tab Order 
command. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired form in Design view. 

3. Select the View menu. 

4. Select the Tab Order command. 
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5. Select Auto Order. 

6. Select OK. 

 

SETTING THE TAB ORDER MANUALLY 

 Discussion 
The tab order determines the order in which form fields and controls are selected 
when you press the [Tab] key during data entry. The default tab order is the order in 
which the fields or controls were added to the form. If you have added, rearranged, or 
deleted fields or controls, the tab order may not be suitable for data entry. You can 
adjust the tab order manually to reflect whatever order is best for your data entry 
needs. 
 

 Steps 

1. Open the desired database. 

2. Open the desired form in Design view. 

3. Select the View menu. 

4. Select the Tab Order command. 

5. Point to the record selector to the left of the field you want to move. 

6. Select the record selector to the left of the field you want to move. 

7. Drag the field to the new position. 

8. Select OK. 

 

ADDING A FORM HEADER AND FOOTER 

 Discussion 
The Form Header and Form Footer sections display at the top and bottom of the 
form in Form view. They are stationary when you scroll the Detail section, making 
them useful for displaying titles or instructions you want visible on the form at all 
times. If you print the form, these sections appear at the top of the first page and the 
bottom of the last page. 
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You can place controls, including images, labels, and fields, in the form header or 
footer. 

 
A label added to the Form Header section 

 
  

 
You can also display the Form Header and Form Footer 
sections by right-clicking in the Design window and then 
selecting the Form Header/Footer command. 

  

 
You can also add Page Header and Page Footer sections to a 
form by selecting the View menu and then selecting the Page 
Header/Footer command. Page headers and footers only 
appear when the form is printed. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired form in Design view. 

3. Display the toolbox. 

4. Select the View menu. 

5. Select the Form Header/Footer command. 
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CREATING A BLANK FORM 

 Discussion 
You can create a form from scratch in Design view. For example, if a form does not 
currently exist for a particular table or query, you can create one using the fields in the 
selected table or query. You can then determine the design of the form by adding 
fields, control, and options. 

 
A form created from scratch 

 

 Steps 

1. Open the desired database. 

2. Display the Forms object list. 

3. Select the New button  on the Database window toolbar. 

4. Select Design View. 

5. Select the Choose the table or query where the object’s data 
comes from list. 

6. Select the table or query on which you want to base the form. 

7. Select OK. 

8. Add items to the form as desired. 
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LESSON 4 -  
USING ADVANCED REPORT DESIGN  

In this lesson, you will learn how to: 

• Use reports in Design view  

• Create a calculated control  

• Group data in a report  

• Create a header for each group  

• Create a running summary  

• Insert a date/time control  

• Insert a page break  

• Change the report margins  

• Use the Label Wizard  

• Create a blank report  
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USING REPORTS IN DESIGN VIEW 

 Discussion 
You can create or customize a report in Design view. A report has three basic 
sections: Detail, Report Header/Footer, and Page Header/Footer. 
 
The Detail section contains the information from the table or query. You create 
controls in the Detail section that display information. You can display either one 
record per page or multiple records per page. 
 
The Report Header and Report Footer sections display at the top and bottom of the 
report in Design view. When you print the report, these sections appear at the 
beginning and the end of the report only. The header can be used for report titles, 
while the footer can be used for report totals or other summaries. 
 
The Page Header and Page Footer sections display at the top and bottom of the 
report in Design view. When the report is printed, these sections appear at the top and 
bottom of every page. Page headers and footers can contain images, lines, text, or any 
other controls you want printed on every page. 
 
When you enable the display of either header and footer section, both the header and 
the footer appear. You can drag the header and footer sections to size them. 
 

CREATING A CALCULATED CONTROL 

 Discussion 
You can add a calculated control to a form or report. A calculated control is not bound 
to a field. It contains an expression that uses information from fields to calculate a 
result. The result is not stored in a table. It is calculated when the report or form is run. 
The Control Source property defines the expression that calculates the result. 
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A calculated control created in a report 

 
  

 
You can also open the property sheet by right-clicking the new 
text box and then selecting the Properties command or by 
selecting the View menu and then selecting the Properties 
command. 

  

 
You can also create an expression using the Expression 
Builder by clicking the Expression Builder button to the right 
of the Control Source property on the Data page in the 
property sheet, by clicking the Build button on the Form 
Design toolbar, or by right-clicking in the Control Source 
property and then selecting the Build command. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Display the toolbox. 

4. Click the Text Box tool  in the toolbox. 

5. Click in the desired location for the control. 

6. Click the Properties button  on the Report Design toolbar. 

7. Select the Data tab. 
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8. Type the desired calculated control expression. 

9. Click the Close button to close the property sheet. 

10. Select the label box paired with the control. 

11. Press [Delete]. 

 

GROUPING DATA IN A REPORT 

 Discussion 
You can group data in reports that have a common field. It is often easier to read 
reports when data is grouped, since you can then easily find the pertinent data. For 
example, you can group a sales report by region so that regional personnel can easily 
locate the data for their region. 
 
A grouped report automatically sorts the table by the data in the grouped field. You 
can nest groups inside one another, up to ten levels. For example, in the regional 
report, you may want to group by state within each region. 
 
When you group data, you can display a group header and footer that can be used to 
display information at the top or bottom of each group. For example, you can add a 
calculated control in a group footer that calculates summary information, such as a 
total or an average for each group. 
 

 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Click the Sorting And Grouping button  on the Report 
Design toolbar. 

4. Select the Field/Expression list. 

5. Select the desired field. 

6. Select the corresponding Sort Order field. 

7. Select the Sort Order list. 

8. Select the desired sort order. 

9. Select the Group Header property box. 
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10. Select the Group Header list. 

11. Select the desired option. 

12. Select the Group Footer property box. 

13. Select the Group Footer list. 

14. Select the desired option. 

15. Select the Group On property box. 

16. Select the Group On list. 

17. Select the desired option. 

18. Click the Close button. 

 

CREATING A HEADER FOR EACH GROUP 

 Discussion 
You can create a header for each group that appears in a grouped report. The header 
displays at the top of each group. Often, the group header contains the control for the 
grouped field, meaning that the common value on which the grouping is based, such 
as the region, appears only once at the top of each group. 

 
A group header in a report 
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 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Select the control you want to insert into the group header. 

4. Click the Cut button  on the Formatting (Form/Report) 
toolbar. 

5. Click the desired group header section where you want the header to 
appear. 

6. Click the Paste button  on the Formatting (Form/Report) 
toolbar. 

 

CREATING A RUNNING SUMMARY 

 Discussion 
In a grouped report, you can create a running summary of the items in the group. 
Often, the running summary is positioned in the group footer, which appears at the 
bottom of every group. For example, in a sales report grouped by region, you can 
create a calculated field that displays information in a running summary. After each 
group, a cumulative total for all the groups above appears. 

 
An expression used to create a running summary in a report 
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You can also open the property sheet by right-clicking the new 
text box and then selecting the Properties command or by 
selecting the View menu and then selecting the Properties 
command. 

  

 
You can also create an expression using the Expression 
Builder by clicking the Expression Builder button to the right 
of the Control Source property on the Data page in the 
property sheet, by clicking the Build button on the Form 
Design toolbar, or by right-clicking in the Control Source 
property and then selecting the Build command. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Display the toolbox. 

4. Click the Text Box tool  in the toolbox. 

5. Click in the location for the control. 

6. Click the Properties button  on the Report Design toolbar. 

7. Select the Data tab. 

8. Type the desired calculated control expression. 

9. Select the Running Sum property. 

10. Select the Running Sum list. 

11. Select the desired option. 

12. Click the Close button to close the property sheet. 

 

INSERTING A DATE/TIME CONTROL 

 Discussion 
You can insert a control that displays the current date and/or time in a report. This 
control updates automatically every time the report is previewed or printed. By 
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default, a date/time control is inserted into the Report Header section. However, you 
can easily move it to another section. For example, you could place the date in the 
Report Footer section so that it would be readily visible on the last page of the report. 
 

  

 
If you create a report with the Report Wizard, Access 
automatically inserts a date/time control in the Page Footer 
section. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Select the Insert menu. 

4. Select the Date and Time command. 

5. Select or deselect options as desired. 

6. Select OK. 

7. Drag the date control to the desired position in the report. 

 

INSERTING A PAGE BREAK 

 Discussion 
When you print a report, Access automatically starts a new page when necessary. You 
can control the pagination by inserting a page break. You can insert a page break in 
the Group Footer section to place each group on its own page, or you can insert a 
page break in the Report Header section to create a separate title page for a report. 
 

 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Display the toolbox. 
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4. Click the Page Break tool  in the toolbox. 

5. Click in the location for the page break. 

 

CHANGING THE REPORT MARGINS 

 Discussion 
By default, the margins for a report are one inch on all sides. You can control the 
margin settings to fit more or less data on a page as necessary. The margins you set 
for a report are saved and applied each time you print the report. 
 

 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Select the File menu. 

4. Select the Page Setup command. 

5. Select the text in the Top text box. 

6. Type the new measurement for the top margin. 

7. Select the text in the Bottom text box. 

8. Type the new measurement for the bottom margin. 

9. Select the text in the Left text box. 

10. Type the new measurement for the left margin. 

11. Select the text in the Right text box. 

12. Type the new measurement for the right margin. 

13. Select OK. 
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USING THE LABEL WIZARD 

 Discussion 
Access has a Label Wizard that guides you through the process of creating a report 
that prints labels. You can choose from many standard types of labels, or you can 
create your own custom label definition. 

 
Labels created using the Label Wizard 

 

 Steps 

1. Open the desired database. 

2. Display the Reports object list in the Database window. 

3. Select the New button  on the Database window toolbar. 

4. Select Label Wizard. 

5. Select the Choose the table or query where the object’s data 
comes from list. 

6. Select the desired table or query. 

7. Select OK. 

8. Select the desired unit of measurement under Unit of Measure. 

9. Select the Filter by manufacturer list. 
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10. Select the desired label manufacturers. 

11. Select the desired label type under Product number in the What 
label size would you like? list box. 

12. Select Next. 

13. Select the desired font and color options. 

14. Continue selecting the desired font and color options. 

15. Select Next. 

16. Select the field for the first row from the Available fields list box.. 

17. Press [Enter]. 

18. Continue adding fields from the Available fields list box, as 
appropriate. 

19. Select Next. 

20. Add the field by which you want to sort from the Available fields 
list box. 

21. Select Next. 

22. Type a name for the report. 

23. Select Finish. 

 

CREATING A BLANK REPORT 

 Discussion 
You can create a report from scratch in Design view. For example, if a report does not 
currently exist for a particular table or query, you can create one using the fields in the 
selected table or query. You can then determine the design of the report by adding 
fields, control, and options. 
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A report created from scratch 

 

 Steps 

1. Open the desired database. 

2. Display the Reports object list. 

3. Select the New button  on the Database window toolbar. 

4. Select Design View. 

5. Select the Choose the table or query where the object’s data 
comes from list. 

6. Select the table or query on which you want to base the report. 

7. Select OK. 

8. Add items to the report as desired. 

 



 

 

LESSON 5 -  
USING SUBFORMS/SUBREPORTS  

In this lesson, you will learn how to: 

• Work with subforms/subreports  

• Create a subform/subreport  

• Edit the layout of a subform  

• Display a subform in Datasheet view  

• Add a subform header/footer  

• Display a subform total  
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WORKING WITH SUBFORMS/SUBREPORTS 

 Discussion 
You can display a form or report within a form or report. The main form or report 
includes information from one table and the subform or subreport includes 
information from a second, related table. 
 
You can show a form or report within a form or report to more effectively show the 
linked data from tables with one-to-many relationships. The main form/report and the 
subform/subreport are linked by a common field between the tables. The main 
form/report represents the one side of the one-to-many relationship and the 
subform/subreport represents the many side. When viewing a record in the main 
form/report (one side relationship), the subform/subreport displays the related records 
from another table (many side relationship). For example, you have a Customer table 
and an Orders table. Each customer has several orders. In the Customer form (bound 
to the Customer table), you can include an Orders subform (bound to the Orders 
table). The tables would probably be linked by a Customer ID field; a field present in 
both tables. As you view a customer’s record displayed in the main form, the order 
records of that customer appear in the subform. When you move to the next customer 
record in the main form, the order records in the subform are updated to display that 
customer’s orders. Just as you can manipulate table data in a form, you can also 
manipulate the related table data using the subform. Using the same example, you can 
edit the customer records or the order records. 
 
Subform data can be displayed in either Form view (one record at a time) or 
Datasheet view (many records displayed at once), while subreport data can only be 
displayed in Print Preview. 
 
You can add any number of subforms or subreports to a form or report as well as add 
a subform or subreport within another subform or subreport. You should keep in mind 
that the purpose of a form or report is to make viewing and entering data easier. You 
can avoid cluttering the form or report (which can cause confusion) by positioning the 
subform(s) or subreport(s) carefully, assigning a different background color to each, 
and removing any unnecessary items, such as scroll bars. Viewing the properties of 
the subform or subreport is helpful when considering these options. 
 
The Subform and SubReport Wizards provide the easiest method for creating a 
subform or subreport. If you choose not to use the Subform or Subreport Wizards, you 
will need to design a form or report and then insert it into another form or report. You 
may not want to use the wizard if you are designing a subform or subreport that is 
very different in appearance from the form or report the wizard produces. 
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CREATING A SUBFORM/SUBREPORT 

 Discussion 
When you add a subform/subreport to an existing form, it is best to start by creating 
the main form/report before you create the subform/subreport. The form/report can 
then be edited so that it contains only the information you need, as well as the desired 
layout. This form can be added to the design of the main form where it will take on 
the properties of a subform/subreport. 
 
You can create a subform that will appear in Form view, Datasheet view, or both 
views. When the form is created using the SubForm Wizard, a subform is created that 
can be viewed in both Form and Datasheet views. You can customize the subform in 
Design view by adding headers, footers, color, fonts, totals, etc. 
 
The SubForm/SubReport Wizard prompts you for the following information: 

 
1. If you want to use an existing form/report as the subform/subreport 

or build a new one from tables and queries. 

2. If you want to define the link between the main form/report and 
subform/subreport yourself or choose from a list of available link 
options. 

3. A name for the subform or subreport. 

 

 
A subform within a form 
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Although it is not necessary to click the Control Wizards 
button before creating a subform or subreport, it is 
recommended. Clicking this button enables the control 
wizards that assist you in creating a subform or subreport. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired form or report in Design view. 

3. Click the Control Wizards button  in the toolbox, if necessary. 

4. Click the Subform/Subreport button  in the toolbox. 

5. Click in the form or report where you want to place the top left 
corner of the subform or subreport. 

6. Select the desired option for the source of the subform or subreport. 

7. Select the desired form or report you want to insert as a subform or 
subreport. 

8. Select Next. 

9. Select the desired link option. 

10. Select the desired link for the subform or subreport from the list box. 

11. Select Next. 

12. Type a name for the subform or subreport. 

13. Select Finish. 

 

EDITING THE LAYOUT OF A SUBFORM 

 Discussion 
In order to improve the efficiency or appearance of a subform/subreport, you can 
change its layout the same way you would change the layout of a form/report. In 
Design view for the main form/report, the subform/subreport is a control that you can 
move, resize, align, add, and delete as you would any other control. Since the 
subform/subreport control contains a form/report, you can open it in Design view and 
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make any editing changes to its controls. Any changes to the layout of the 
subform/subreport are performed in Design view. 
 

 Steps 

1. Open the desired database. 

2. Open the main form in Design view. 

3. Double-click the subform control you want to edit. 

4. Double-click the subform control text to select it. 

5. Make the desired editing changes. 

 

DISPLAYING A SUBFORM IN DATASHEET VIEW 

 Discussion 
You can display a subform in Datasheet view. This option allows you to view many 
subform records at once, rather than viewing them one at a time in Form view. Since 
the benefit of using subforms is to display the “many” side of a one-to-many 
relationship, Datasheet view is generally preferred. 

 
A subform in Datasheet view 
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You can add a record to both the main form and the subform 
by selecting the Insert menu and then selecting the New 
Record command. 

  

 
You can also display a subform in Datasheet view by right-
clicking in the desired field and then selecting the Subform 
Datasheet command. 

  
 

 Steps 

1. Open the desired database. 

2. Open the main form in Form view. 

3. Select a field in the subform. 

4. Select the View menu. 

5. Select the Subform Datasheet command. 

 

ADDING A SUBFORM HEADER/FOOTER 

 Discussion 
You can add headers and footers to subforms/subreports when the subform/subreport 
is open in Design view. Access includes page headers and footers and form/report 
headers and footers. Page headers and footers appear on each page of a form, whereas 
form/report headers and footers only appear once on a form/report (form/report 
headers at the beginning of the subform/subreport and form/report footers at the end). 
Headers are generally used to provide information about the subform/subreport, such 
as a title, while footers are generally used to display summary information about the 
subform/subreport data, such as a total. 
 
The different headers and footers are described in the following table: 

 
Type Description 

Page Header Displays information you want at the top of every 
page, such as a title or column heading. 

Page Footer Displays information you want at the bottom of every 
page, such as a page number or filename. 
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Type Description 

Form/Report 
Header 

Displays information at the top of the first printed 
page only, such as instructions on using the 
form/report. A button could be included here that 
could open a related form/report. The Form/Report 
Header does not appear in Datasheet view. 

Form/Report 
Footer 

Displays information at the bottom of the last printed 
page only, such as instructions on using the 
form/report. A button could be included here that 
could open a related form/report. The Form/Report 
Footer does not appear in Datasheet view. 

 

 
A form header displayed in a subform 

 
  

 
You can also add a form header/footer by right-clicking in the 
Detail section and then selecting the Form Header/Footer 
command. 

  

 
You can add a report header/footer in the same way that you 
add a form header/footer. However, instead of selecting the 
Form Header/Footer command, you would select the Report 
Header/Footer command. 
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 Steps 

1. Open the desired database. 

2. Open the main form in Design view. 

3. Double-click the subform Detail header. 

4. Select the View menu. 

5. Select the Form Header/Footer command. 

6. Click the Label button  in the toolbox. 

7. Click in the location in which you want to add the form header or 
footer. 

8. Type the desired text for the header or footer. 

9. Click outside the label box to enter the text into the subform. 

 

DISPLAYING A SUBFORM TOTAL 

 Discussion 
Forms and reports often include totals of the information they contain. These totals are 
easily created by adding a calculated control to the form/report that contains an 
expression to find the desired total. Expressions are used to obtain information you 
cannot obtain directly from the tables in your database. For example, if you have a 
table that contains the quantity and cost of various items, you could use an expression 
to multiply the quantity and the cost to obtain the current inventory value. Every time 
you use a form/report, Access calculates any expressions contained in the form/report, 
helping you keep your information as accurate as possible. 
 
Some examples of expressions are listed in the following table: 
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Control 
Name 

Expression Result 

Total =[Cost]+[Shipping]+[Markup] Adds the value of the 
Cost field, the value of 
the Shipping field, and 
the value of the Markup 
field of an item to 
produce the Total field 

Discount =[Price]*.15 Multiplies the Price field 
of an item by a constant 
discount of 0.15 

Date =Date() Provides the current date 
in your computer system 

 
You may want to include a total of information, contained in a subform/subreport, in 
the main form/report total. For example, an Orders form may contain a control for 
shipping charges. The information in the Product subform may include a total, such 
as the total cost of all the products ordered. You can display this subform total on the 
main form so that you can add the shipping charges to this total to create a grand total. 
This option is performed by adding a control to the main form/report, which refers to 
the desired subform/subreport total control, to display the information. 
 
The expression in the main form/report control that refers to the subform/subreport 
control defines the name of the subform/subreport and the name of the 
subform/subreport control being used in the following format: 

 
= [Name of the Subform/Subreport]![Name of the Subform/Subreport Control] 

 
A subform total displayed in the main form 
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You can also display a subreport total in the main report using 
the same methods that you use to display a subform total. 

  

 
You can also display the property sheet by selecting the View 
menu and then selecting the Properties command or by right-
clicking a form or report in Design view and then selecting the 
Properties command. 

  
 

 Steps 

1. Open the desired database. 

2. Open the form in Design view. 

3. Click the Text Box button  in the toolbox. 

4. Click in the form where you want to insert the control. 

5. Select the label box. 

6. Select the text in the label box. 

7. Type a label in the label box. 

8. Select the text box. 

9. Click the Properties button  on the Form Design toolbar. 

10. Select the Data tab. 

11. Type the expression that refers to the desired subform control. 

12. Click the Close button to close the property sheet. 

 



 

 

LESSON 6 -  
USING OTHER FORM TECHNIQUES  

In this lesson, you will learn how to: 

• View the properties of an object  

• Change a control property  

• Add a logic control  

• Add a command button  

• Save a form as a report  

• Create a form letter  
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VIEWING THE PROPERTIES OF AN OBJECT 

 Discussion 
Every object in Access has properties that define its characteristics. Database objects, 
such as tables, queries, and forms, have very general properties, such as their name 
and description. Other objects, such as fields in a table or controls on a form, have 
many properties that control their appearance, such as font size and color, the number 
of decimal places, and the control source. You can change the properties of the objects 
on a form or report in Design view using the property sheet. The properties displayed 
on the property sheet depend on what type of object is selected. For example, the 
properties for a label box differ from the properties for the Detail section of a form. 
You can also change the properties for page and form headers and footers. 
 
The properties of objects are grouped into five categories: 

 
Category Description 

Format Specifies the appearance of objects, such as font 
characteristics of a text box or whether or not scroll bars 
appear on a form. 

Data Determines the characteristics of the data displayed, such 
as the data’s control source, default value, or whether or 
not it can be edited.  

Event Specifies a procedure that Access executes when an event 
occurs. Some examples of events include clicking a 
control (OnClick), deleting data (OnDelete), and opening 
the form (OnOpen). The procedure can be an expression, 
a macro, or a Visual Basic for Access routine. 

Other Shows additional features of the control, such as the 
name of the control or whether or not a control is in the 
tab order. 

All Displays all the properties of the object in one list. 

 
 

  

 
You can also display the property sheet by selecting the View 
menu and then selecting the Properties command or by right-
clicking a form or report in Design view and then selecting the 
Properties command. 

  

 
The name of the selected object appears in the title bar of the 
property sheet. 
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 Steps 

1. Open the desired database. 

2. Open the desired form or report in Design view. 

3. Select the desired object. 

4. Click the Properties button  on the Form Design toolbar. 

5. Select the desired tab on the property sheet. 

 

CHANGING A CONTROL PROPERTY 

 Discussion 
The properties of a control define many of its aspects, including the source of the 
information displayed in the control, its name, if it is displayed or hidden, and its 
appearance (font size, color, etc.). Properties of controls and other objects can be 
easily changed to suit your needs. For example, you may have a form with records 
you want to keep constant. You can select No in the form’s Allow Edits property box 
to prevent any editing of the records. 

 
The Format page of the property sheet 
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You can change the properties of several controls at once. For 
example, you can select several text boxes and change the font 
type and size for all of them at the same time, rather than 
individually. 

  

 
You can double-click a label box or text box to quickly change 
a property setting. This option is especially helpful for 
properties that can be set to Yes or No only. 

  
 

 Steps 

1. Open the desired database. 

2. Open the desired form or report in Design view. 

3. Select the desired control. 

4. Click the Properties button  on the Form Design toolbar. 

5. Select the desired tab on the property sheet. 

6. Select the desired property you want to set. 

7. Select the list for the property, if appropriate. 

8. Type the desired property setting or choose a property setting from 
the list. 

9. Click the Close button to close the property sheet. 

 

ADDING A LOGIC CONTROL 

 Discussion 
Some tables contain fields that have a Yes/No field type. These fields can contain a 
Yes (True) value, a No (False) value, or no value at all. 
 
When working with a form that contains a Yes/No field, you can create a logic control 
that is bound to the Yes/No field. Logic controls give a visual display of the value in a 
Yes/No field, such as a check box where a check mark appears when the field value is 
Yes and does not appear when the value is No. Another type of logic control is the 
toggle button, which appears “sunken” for a value of Yes and “raised” for a value of 
No. The logic control for a field with a null value (neither Yes nor No is chosen) 
appears the same as the field with a No value. 



Creating Forms and Reports Using Access 2000 Lesson 6 - Using Other Form Techniques 

US Senate Office of Education and Training Page 61
 

 
Logic controls improve the visual effectiveness of a form and facilitate data entry. 
With a logic control, the value of a Yes/No field is selected with a single click of the 
mouse button rather than multiple keystrokes. 
 
The way in which the different controls indicate a Yes or No value are described in 
the following table: 

 
Control Appearance 

Toggle button Appears “sunken” with a Yes value and “raised” with 
a No value. 

Option button Contains a dot with a Yes value and appears empty 
with a No value. 

Check box Appears checked with a Yes value and unchecked 
with a No value. 

 
 

 Steps 

1. Open the desired database. 

2. Open the desired form in Design view. 

3. Click the desired logic control tool in the toolbox. 

4. Click in the form where you want the logic control to appear. 

5. Select the label box of the logic control. 

6. Click in the text in the label box. 

7. Select the default text. 

8. Type the desired logic control name. 

9. Select the logic control. 

10. Click the Properties button  on the Form Design toolbar. 

11. Select the Data tab. 

12. Select the Control Source list. 

13. Select the Yes/No field you want bound to the logic control. 

14. Click the Close button to close the property sheet. 
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ADDING A COMMAND BUTTON 

 Discussion 
You can design one or more command buttons to appear on a form. These command 
buttons can then be used to access commonly used functions. For example, if you 
frequently use the Calculator, you can create a command button that can simply be 
clicked to instantly access the Calculator. 
 
Command buttons are particularly useful because they do not require the database 
user to know the Microsoft Access menu structure. For example, instead of making 
the user select the Print command from the File menu to print a displayed form, you 
could add the Print function to a command button on the form. 
 
Access provides different actions for you to use, which are available in the following 
categories: Record Navigation, Record Operations, Form Operations, Report 
Operations, Application, and Miscellaneous. 

 
Adding a command button 

 
  

 
If you click the Control Wizards button before you create a 
command button, Access provides you with a wizard that 
helps you create the command button. 
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 Steps 

1. Open the desired database. 

2. Open the desired form in Design view. 

3. Click the Control Wizards button  in the toolbox. 

4. Click the Command Button tool  in the toolbox. 

5. Click in the form where you want to insert the command button. 

6. Select the desired category from the Categories list box. 

7. Select the desired action from the Actions list box. 

8. Select Next. 

9. Type the path to the application you want to run. 

10. Select Next. 

11. Select whether you want text or a picture to display on the button. 

12. Select the text in the Text text box or select the desired picture. 

13. Type the text you want to appear on the button, as necessary. 

14. Select Next. 

15. Type the desired name for the button. 

16. Select Finish. 

 

SAVING A FORM AS A REPORT 

 Discussion 
If you have an existing form you print often, you can save the form as a report. It is 
possible to print a form directly, but reports are more suitable for presenting 
information on paper, especially if you need to include group totals. Once a form is 
saved as a report, its structure can be modified in Report Design view to suit your 
needs. 
 

  

 
You can also open the Save As dialog box by selecting the 
desired form in the Database window, selecting the File menu, 
and then selecting the Save As command. 
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 Steps 

1. Open the desired database. 

2. Display the Forms object list. 

3. Right-click the form you want to save as a report. 

4. Select the Save As command. 

5. Type a name for the report. 

6. Select the As list. 

7. Select the desired Report or Form item. 

8. Select OK. 

 

CREATING A FORM LETTER 

 Discussion 
You can create a form letter with Access. A form letter is a report that contains static 
(constant) text, such as the body of a letter or an invoice form, and has controls that 
are bound to table data and embedded in the appropriate locations on the form letter. 
A simple example of a form letter is a report in which the text “Dear” is in the label 
box of a control and the text box of the control is bound to the First Name field of a 
table. When this report is run, the greeting of each form letter appears as follows: 

 
Dear Joseph: 
 
Dear Emily: 
 
Dear Susan: 

 
The “Dear” remains as constant text and the first names are supplied by the table. 
 
When you create a form letter, you need to tell Access which table or query you want 
to use to provide the data that will be used in the form letter. 

 
When you create a form letter in Access, it is important to remember that the label 
boxes contain the static, or unchanging, text of the letter. The text boxes are bound 
controls that change to display the appropriate field data from each record. When you 
use the toolbox in Report Design view to add a text box control, a label box control 
automatically appears to the left of it. You can delete the label box if you do not need 
it. 



Creating Forms and Reports Using Access 2000 Lesson 6 - Using Other Form Techniques 

US Senate Office of Education and Training Page 65
 

 
In most cases, it is necessary to insert at least one page break to ensure that the letters 
are printed individually. 

 
A form letter 

 

 Steps 

1. Open the desired database. 

2. Open the desired report in Design view. 

3. Click the Label tool  in the toolbox. 

4. Click in the report where you want the static text to appear. 

5. Type the desired static text. 

6. Click the Text Box tool  in the toolbox. 

7. Click in the report where you want the text box to appear. 

8. Select the label box control. 

9. Press [Delete]. 

10. Select the text box control. 

11. Click the Properties button  on the Formatting 
(Form/Report) toolbar. 

12. Select the Data tab. 
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13. Select the Control Source list. 

14. Select the field name you want bound to the text box control. 

15. Click the Close button to close the property sheet. 
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Margins 
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viewing properties, 58, 59 
Option groups 

creating, 28, 29 
Page breaks 
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displaying a total, 54, 56 
displaying in Datasheet view, 51, 52 
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adding a report header, 52 
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working with, 48 
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